PHP 7.3.x < 7.3.16 Multiple Vulnerabilities

Medium Nessus Plugin ID 134944


The version of PHP running on the remote web server is affected by multiple vulnerabilities.


According to its banner, the version of PHP running on the remote web server is 7.3.x prior to 7.3.16. It is, therefore, affected by the following vulnerabilities:

- An out of bounds read resulting in the use of an uninitialized value in exif (CVE-2020-7064)

- A stack buffer overflow in allows overwriting of a stack-allocated buffer with an overflown array from .rodata. (CVE-2020-7065)

- get_headers() silently truncates anything after a null byte in the URL it uses. An unauthenticated, remote attacker can exploit this to leak sensitive information or cause the web server to unexpectedly process attacker-controlled data. (CVE-2020-7066) Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 7.3.16 or later.

See Also

Plugin Details

Severity: Medium

ID: 134944

File Name: php_7_3_16.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2020/03/27

Updated: 2020/04/24

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2020-7065

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/03/19

Vulnerability Publication Date: 2020/03/19

Reference Information

CVE: CVE-2020-7064, CVE-2020-7065, CVE-2020-7066

IAVA: 2020-A-0117-S