openSUSE Security Update : mcpp (openSUSE-2020-382)

Medium Nessus Plugin ID 134936

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for mcpp fixes the following issues :

- CVE-2019-14274: Fixed a heap-based buffer overflow in the do_msg() (boo#1143032)

Solution

Update the affected mcpp packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1143032

Plugin Details

Severity: Medium

ID: 134936

File Name: openSUSE-2020-382.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2020/03/26

Updated: 2020/03/30

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libmcpp0, p-cpe:/a:novell:opensuse:libmcpp0-debuginfo, p-cpe:/a:novell:opensuse:mcpp, p-cpe:/a:novell:opensuse:mcpp-debuginfo, p-cpe:/a:novell:opensuse:mcpp-debugsource, p-cpe:/a:novell:opensuse:mcpp-devel, cpe:/o:novell:opensuse:15.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/03/25

Vulnerability Publication Date: 2019/07/26

Reference Information

CVE: CVE-2019-14274