NewStart CGSL MAIN 4.05 : git Vulnerability (NS-SA-2020-0023)

High Nessus Plugin ID 134311

Synopsis

The remote machine is affected by a vulnerability.

Description

The remote NewStart CGSL host, running version MAIN 4.05, has git packages installed that are affected by a vulnerability:

- Git before 2.14.5, 2.15.x before 2.15.3, 2.16.x before 2.16.5, 2.17.x before 2.17.2, 2.18.x before 2.18.1, and 2.19.x before 2.19.1 allows remote code execution during processing of a recursive git clone of a superproject if a .gitmodules file has a URL field beginning with a '-' character. (CVE-2018-17456)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL git packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2020-0023

Plugin Details

Severity: High

ID: 134311

File Name: newstart_cgsl_NS-SA-2020-0023_git.nasl

Version: 1.2

Type: local

Published: 2020/03/08

Updated: 2020/03/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-17456

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2020/03/04

Vulnerability Publication Date: 2018/10/06

Reference Information

CVE: CVE-2018-17456

BID: 105523, 107511