SUSE SLED15 / SLES15 Security Update : libvpx (SUSE-SU-2020:0143-1)

high Nessus Plugin ID 133141
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for libvpx fixes the following issues :

CVE-2019-2126: Fixed a double free in ParseContentEncodingEntry() (bsc#1160611).

CVE-2019-9325: Fixed an out-of-bounds read (bsc#1160612).

CVE-2019-9232: Fixed an out-of-bounds memory access on fuzzed data (bsc#1160613).

CVE-2019-9433: Fixed a use-after-free in vp8_deblock() (bsc#1160614).

CVE-2019-9371: Fixed a resource exhaustion after memory leak (bsc#1160615).

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Server for SAP 15 :

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-143=1

SUSE Linux Enterprise Server 15-LTSS :

zypper in -t patch SUSE-SLE-Product-SLES-15-2020-143=1

SUSE Linux Enterprise Module for Packagehub Subpackages 15 :

zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-2020-143=1

SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 :

zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-143=1

SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 :

zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2020-143=1

SUSE Linux Enterprise Module for Desktop Applications 15-SP1 :

zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-143=1

SUSE Linux Enterprise Module for Desktop Applications 15 :

zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2020-143=1

SUSE Linux Enterprise Module for Basesystem 15-SP1 :

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-143=1

SUSE Linux Enterprise Module for Basesystem 15 :

zypper in -t patch SUSE-SLE-Module-Basesystem-15-2020-143=1

SUSE Linux Enterprise High Performance Computing 15-LTSS :

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-143=1

SUSE Linux Enterprise High Performance Computing 15-ESPOS :

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-143=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1160611

https://bugzilla.suse.com/show_bug.cgi?id=1160612

https://bugzilla.suse.com/show_bug.cgi?id=1160613

https://bugzilla.suse.com/show_bug.cgi?id=1160614

https://bugzilla.suse.com/show_bug.cgi?id=1160615

https://www.suse.com/security/cve/CVE-2019-2126/

https://www.suse.com/security/cve/CVE-2019-9232/

https://www.suse.com/security/cve/CVE-2019-9325/

https://www.suse.com/security/cve/CVE-2019-9371/

https://www.suse.com/security/cve/CVE-2019-9433/

http://www.nessus.org/u?3f480294

Plugin Details

Severity: High

ID: 133141

File Name: suse_SU-2020-0143-1.nasl

Version: 1.4

Type: local

Agent: unix

Published: 1/21/2020

Updated: 1/13/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libvpx-debugsource, p-cpe:/a:novell:suse_linux:libvpx-devel, p-cpe:/a:novell:suse_linux:libvpx4, p-cpe:/a:novell:suse_linux:libvpx4-32bit-debuginfo, p-cpe:/a:novell:suse_linux:libvpx4-debuginfo, p-cpe:/a:novell:suse_linux:vpx-tools, p-cpe:/a:novell:suse_linux:vpx-tools-debuginfo, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 1/20/2020

Vulnerability Publication Date: 8/20/2019

Reference Information

CVE: CVE-2019-2126, CVE-2019-9232, CVE-2019-9325, CVE-2019-9371, CVE-2019-9433