WordPress < 5.3.1

Medium Nessus Plugin ID 132099

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3

Synopsis

A PHP application running on the remote web server is affected by a vulnerability.

Description

WordPress versions 5.3.0 and earlier are affected by the following vulnerabilities:

- Two cross-site scripting (XSS) vulnerabilities exist due to improper validation of user-supplied input.
An unauthenticated, remote attacker can exploit these, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

- A remote, authenticated, unprivileged user can make a post sticky via the REST API.

- wp_kses_bad_protcol() has been hardened to ensure that it is aware of the named colon attribute.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to WordPress version 5.3.1 or later.

See Also

https://wordpress.org/support/wordpress-version/version-5-3-1/

Plugin Details

Severity: Medium

ID: 132099

File Name: wordpress_5_3_1.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 2019/12/18

Updated: 2020/05/08

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 3

CVSS Score Source: CVE-2019-20042

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/12/12

Vulnerability Publication Date: 2019/12/12

Reference Information

CVE: CVE-2019-20042

IAVA: 2019-A-0462-S