PHP 7.4.x < 7.4.0 Multiple Vulnerabilities.

High Nessus Plugin ID 131732

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 9

Synopsis

An application installed on the remote host is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.4.x prior to 7.4.0. It is, therefore, affected by multiple vulnerabilities including a buffer overflow

Solution

Upgrade to PHP version 7.4.0 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.4

https://bugs.php.net/bug.php?id=72530

Plugin Details

Severity: High

ID: 131732

File Name: php_7_4_0.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2019/12/06

Updated: 2020/03/06

Dependencies: 48243

Risk Information

Risk Factor: High

VPR Score: 9

CVSS Score Source: CVE-2019-11043

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/08/29

Vulnerability Publication Date: 2019/08/29

Exploitable With

Metasploit (PHP-FPM Underflow RCE)

Reference Information

CVE: CVE-2019-11041, CVE-2019-11042, CVE-2019-11043