openSUSE Security Update : libidn2 (openSUSE-2019-2613)

critical Nessus Plugin ID 131684

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for libidn2 to version 2.2.0 fixes the following issues :

- CVE-2019-12290: Fixed an improper round-trip check when converting A-labels to U-labels (bsc#1154884).

- CVE-2019-18224: Fixed a heap-based buffer overflow that was caused by long domain strings (bsc#1154887).

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected libidn2 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1154884

https://bugzilla.opensuse.org/show_bug.cgi?id=1154887

Plugin Details

Severity: Critical

ID: 131684

File Name: openSUSE-2019-2613.nasl

Version: 1.4

Type: local

Agent: unix

Published: 12/4/2019

Updated: 1/19/2021

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libidn2-0, p-cpe:/a:novell:opensuse:libidn2-0-32bit, p-cpe:/a:novell:opensuse:libidn2-0-32bit-debuginfo, p-cpe:/a:novell:opensuse:libidn2-0-debuginfo, p-cpe:/a:novell:opensuse:libidn2-debugsource, p-cpe:/a:novell:opensuse:libidn2-devel, p-cpe:/a:novell:opensuse:libidn2-lang, p-cpe:/a:novell:opensuse:libidn2-tools, p-cpe:/a:novell:opensuse:libidn2-tools-debuginfo, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 12/3/2019

Vulnerability Publication Date: 10/21/2019

Reference Information

CVE: CVE-2019-12290, CVE-2019-18224