PHP < 7.1.33 / 7.2.x < 7.2.24 / 7.3.x < 7.3.11 Remote Code Execution Vulnerability.

High Nessus Plugin ID 130276

Synopsis

An application installed on the remote host is affected by a remote code execution vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is prior to 7.1.33, 7.2.x prior to 7.2.24, or 7.3.x prior to 7.3.11. It is, therefore, affected by a remote code execution vulnerability due to insufficient validation of user input. An unauthenticated, remote attacker can exploit this, by sending a specially crafted request, to cause the execution of arbitrary code by breaking the fastcgi_split_path_info directive.

Solution

Upgrade to PHP version 7.3.11 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.3.11

https://www.php.net/ChangeLog-7.php#7.2.24

https://www.php.net/ChangeLog-7.php#7.1.33

https://bugs.php.net/bug.php?id=78599

Plugin Details

Severity: High

ID: 130276

File Name: php_7_3_11.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2019/10/25

Updated: 2019/11/01

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of the vendor advisory.

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/10/24

Vulnerability Publication Date: 2019/10/24

Reference Information

CVE: CVE-2019-11043

IAVA: 2019-A-0399