Oracle Solaris Critical Patch Update : oct2019_SRU11_4_12_5_0

Medium Nessus Plugin ID 130007

Synopsis

The remote Solaris system is missing a security patch from CPU oct2019.

Description

This Solaris system is missing necessary patches to address a critical security update :

- Vulnerability in the Oracle Solaris product of Oracle Systems (component: XScreenSaver). The supported version that is affected is 11. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where Oracle Solaris executes to compromise Oracle Solaris. While the vulnerability is in Oracle Solaris, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Oracle Solaris.
(CVE-2019-3010)

Solution

Install the oct2019 CPU from the Oracle support website.

See Also

http://www.nessus.org/u?b370bc74

Plugin Details

Severity: Medium

ID: 130007

File Name: solaris_oct2019_SRU11_4_12_5_0.nasl

Version: 1.3

Type: local

Published: 2019/10/17

Updated: 2019/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/o:oracle:solaris

Required KB Items: Host/local_checks_enabled, Host/Solaris11/release

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/10/15

Vulnerability Publication Date: 2019/10/16

Exploitable With

Metasploit (Solaris xscreensaver log Privilege Escalation)

Reference Information

CVE: CVE-2019-3010

IAVA: 2019-A-0381