openSUSE Security Update : nghttp2 (openSUSE-2019-2234) (Data Dribble) (Resource Loop)

high Nessus Plugin ID 129524

Language:

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for nghttp2 fixes the following issues :

Security issues fixed :

- CVE-2019-9513: Fixed HTTP/2 implementation that is vulnerable to resource loops, potentially leading to a denial of service (bsc#1146184).

- CVE-2019-9511: Fixed HTTP/2 implementations that are vulnerable to window size manipulation and stream prioritization manipulation, potentially leading to a denial of service (bsc#11461).

Bug fixes and enhancements :

- Fixed mistake in spec file (bsc#1125689)

- Fixed build issue with boost 1.70.0 (bsc#1134616)

- Feature: Add W&S module (FATE#326776, bsc#1112438) This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected nghttp2 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1112438

https://bugzilla.opensuse.org/show_bug.cgi?id=1125689

https://bugzilla.opensuse.org/show_bug.cgi?id=1134616

https://bugzilla.opensuse.org/show_bug.cgi?id=1146182

https://bugzilla.opensuse.org/show_bug.cgi?id=1146184

https://features.opensuse.org/326776

Plugin Details

Severity: High

ID: 129524

File Name: openSUSE-2019-2234.nasl

Version: 1.4

Type: local

Agent: unix

Published: 10/2/2019

Updated: 1/19/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libnghttp2-14, p-cpe:/a:novell:opensuse:libnghttp2-14-32bit, p-cpe:/a:novell:opensuse:libnghttp2-14-32bit-debuginfo, p-cpe:/a:novell:opensuse:libnghttp2-14-debuginfo, p-cpe:/a:novell:opensuse:libnghttp2-devel, p-cpe:/a:novell:opensuse:libnghttp2_asio-devel, p-cpe:/a:novell:opensuse:libnghttp2_asio1, p-cpe:/a:novell:opensuse:libnghttp2_asio1-32bit, p-cpe:/a:novell:opensuse:libnghttp2_asio1-32bit-debuginfo, p-cpe:/a:novell:opensuse:libnghttp2_asio1-debuginfo, p-cpe:/a:novell:opensuse:nghttp2, p-cpe:/a:novell:opensuse:nghttp2-debuginfo, p-cpe:/a:novell:opensuse:nghttp2-debugsource, p-cpe:/a:novell:opensuse:nghttp2-python-debugsource, p-cpe:/a:novell:opensuse:python3-nghttp2, p-cpe:/a:novell:opensuse:python3-nghttp2-debuginfo, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 10/1/2019

Vulnerability Publication Date: 8/13/2019

Reference Information

CVE: CVE-2019-9511, CVE-2019-9513