Exim 4.92.x < 4.92.3 Heap Buffer Overflow

High Nessus Plugin ID 129470

Synopsis

The remote mail server is potentially affected by a remote code execution vulnerability.

Description

According to its banner, the version of Exim running on the remote host is 4.92.x prior to 4.92.3. It is, therefore, potentially affected by a remote code execution vulnerability allowing unauthenticated, remote attackers to execute arbitrary code via a heap buffer overflow in string_vformat.

Solution

Upgrade to Exim 4.92.3 or later.

See Also

https://www.exim.org/static/doc/security/CVE-2019-16928.txt

Plugin Details

Severity: High

ID: 129470

File Name: exim_4_92_3.nasl

Version: 1.6

Type: remote

Published: 2019/09/30

Updated: 2020/04/10

Dependencies: 10263

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-16928

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/09/27

Vulnerability Publication Date: 2019/09/27

Reference Information

CVE: CVE-2019-16928