MariaDB 10.0.0 < 10.0.8 Multiple Vulnerabilities

Medium Nessus Plugin ID 129360


The remote database server is affected by multiple vulnerabilities


The version of MariaDB installed on the remote host is prior to 10.0.8. It is, therefore, affected by Denial of Service (DOS) vulnerabilities as referenced in the mariadb-1008-release-notes advisory due to errors in the following vectors:

- Error Handling (CVE-2013-5908)
- InnoDB (CVE-2014-0412)
- Replication (CVE-2014-0420)
- Optimizer (CVE-2014-0437)
- Unknown vectors (CVE-2014-0401)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to MariaDB version 10.0.8 or later.

See Also

Plugin Details

Severity: Medium

ID: 129360

File Name: mariadb_10_0_8.nasl

Version: 1.3

Type: remote

Family: Databases

Published: 2019/09/26

Updated: 2019/10/21

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2014-0412

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/02/10

Vulnerability Publication Date: 2014/01/15

Reference Information

CVE: CVE-2013-5908, CVE-2014-0401, CVE-2014-0412, CVE-2014-0420, CVE-2014-0437

BID: 64896, 64898, 64880, 64888, 64849