MariaDB 5.5.0 < 5.5.39 Multiple Vulnerabilities

Medium Nessus Plugin ID 129354

Synopsis

The remote database server is affected by multiple vulnerabilities

Description

The version of MariaDB installed on the remote host is prior to 5.5.39. It is, therefore, affected by multiple vulnerabilities as referenced in the mariadb-5539-release-notes advisory. These vulnerabilites relate to errors in the following components:

- CLIENT:MYSQLADMIN
- CLIENT:MYSQLDUMP
- SERVER:CHARACTER SETS
- SERVER:DDL
- SERVER:DML
- SERVER:MEMORY STORAGE ENGINE
- SERVER:MyISAM
- SERVER:PRIVILEGES AUTHENTICATION PLUGIN API
- SERVER:REPLICATION ROW FORMAT BINARY LOG DML
- SERVER:SSL:yaSSL

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 5.5.39 or later.

See Also

https://mariadb.com/kb/en/mariadb-5539-release-notes

Plugin Details

Severity: Medium

ID: 129354

File Name: mariadb_5_5_39.nasl

Version: 1.4

Type: remote

Family: Databases

Published: 2019/09/26

Updated: 2019/10/31

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2014-6530

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/08/05

Vulnerability Publication Date: 2014/10/15

Reference Information

CVE: CVE-2014-4274, CVE-2014-4287, CVE-2014-6463, CVE-2014-6478, CVE-2014-6484, CVE-2014-6495, CVE-2014-6505, CVE-2014-6520, CVE-2014-6530, CVE-2014-6551, CVE-2015-0391

BID: 69732, 70455, 70462, 70486, 70489, 70496, 70510, 70516, 70517, 70532, 72205