MariaDB 10.0.0 < 10.0.38 Multiple Vulnerabilities

Medium Nessus Plugin ID 129062

Synopsis

The remote database server is affected by multiple vulnerabilities

Description

The version of MariaDB installed on the remote host is prior to 10.0.38. It is, therefore, affected by two vulnerabilities as referenced in the mdb-10038-rn advisory. The vulnerabilities are as follows:

- An unspecified vulnerability in MariaDB in the 'Server: Optimizer' subcomponent could allow a low privileged attacker with network access via multiple protocols to perform a denial of service attack.
(CVE-2019-2529)

- An unspecified vulnerability in MariaDB in the 'Server: DDL' subcomponent could allow a high privileged attacker with network access via multiple protocols to perform a denial of service attack.
(CVE-2019-2537)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 10.0.38 or later.

See Also

https://mariadb.com/kb/en/mdb-10038-rn

Plugin Details

Severity: Medium

ID: 129062

File Name: mariadb_10_0_38.nasl

Version: 1.2

Type: remote

Family: Databases

Published: 2019/09/20

Updated: 2019/10/21

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-2537

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.9

Temporal Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/01/31

Vulnerability Publication Date: 2019/01/16

Reference Information

CVE: CVE-2019-2529, CVE-2019-2537

BID: 106619