MariaDB 5.5.0 < 5.5.63 A Vulnerability

Medium Nessus Plugin ID 129051

Synopsis

The remote database server is affected by a vulnerability

Description

The version of MariaDB installed on the remote host is prior to 5.5.63. It is, therefore, affected by a denial of service vulnerability as referenced in the mdb-5563-rn advisory. This vulnerability is in the 'Server: Optimizer' subcomponent of MariaDB and allows a low privileged attacker to perform a denial of service attack with network access via multiple protocols.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 5.5.63 or later.

See Also

https://mariadb.com/kb/en/mdb-5563-rn

Plugin Details

Severity: Medium

ID: 129051

File Name: mariadb_5_5_63.nasl

Version: 1.3

Type: remote

Family: Databases

Published: 2019/09/19

Updated: 2019/10/17

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-2529

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/01/30

Vulnerability Publication Date: 2019/01/16

Reference Information

CVE: CVE-2019-2529

BID: 106619