MariaDB 10.1.0 < 10.1.41 Multiple Vulnerabilities

Low Nessus Plugin ID 128879

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.4

Synopsis

The remote database server is affected by multiple vulnerabilities

Description

The version of MariaDB installed on the remote host is prior to 10.1.41. It is, therefore, affected by the following vulnerabilities as referenced in the mdb-10141-rn advisory.

- A vulnerability in the 'Server: Pluggable Auth' subcomponent. This is an easily exploitable vulnerability that allows a highly privileged attacker with network access via multiple protocols to compromise the MariaDB Server. Successful attacks involving this vulnerability can result in the unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of the MariaDB Server.
(CVE-2019-2737)

- A vulnerability in the 'Server: Security: Privileges' subcomponent. This is an easily exploitable vulnerability that allows a highly privileged attacker, who is able to logon to the infrastructure where the MariaDB Server executes, to compromise the MariaDB Server. Successful attacks involving this vulnerability can result in the unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MariaDB Server as well as unauthorized update, insert or delete access to some of the data accessible to the MariaDB Server. (CVE-2019-2739)

- A vulnerability in the 'Server: XML' subcomponent. This is an easily exploitable vulnerability that allows a low privileged attacker with network access via multiple protocols to compromise a MariaDB Server.Successful attacks involving this vulnerability can result in the unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of the MariaDB Server.
(CVE-2019-2740)

- A vulnerability in the 'Server: Parser' subcomponent.
This is an easily exploitable vulnerability that allows a low privileged attacker with network access via multiple protocols to compromise the MariaDB Server.
Successful attacks involving this vulnerability can result in the unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of the MariaDB Server. (CVE-2019-2805)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 10.1.41 or later.

See Also

https://mariadb.com/kb/en/mdb-10141-rn

Plugin Details

Severity: Low

ID: 128879

File Name: mariadb_10_1_41.nasl

Version: 1.2

Type: remote

Family: Databases

Published: 2019/09/17

Updated: 2019/10/17

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Low

VPR Score: 4.4

CVSS Score Source: CVE-2019-2739

CVSS v2.0

Base Score: 3.6

Temporal Score: 2.7

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.1

Temporal Score: 4.5

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/07/31

Vulnerability Publication Date: 2019/07/23

Reference Information

CVE: CVE-2019-2737, CVE-2019-2739, CVE-2019-2740, CVE-2019-2805

BID: 109243