openSUSE Security Update : nodejs8 (openSUSE-2019-2115) (0-Length Headers Leak) (Data Dribble) (Empty Frames Flood) (Internal Data Buffering) (Ping Flood) (Reset Flood) (Resource Loop) (Settings Flood)

high Nessus Plugin ID 128669

Language:

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for nodejs8 to version 8.16.1 fixes the following issues :

Security issues fixed :

- CVE-2019-9511: Fixed HTTP/2 implementations that are vulnerable to window size manipulation and stream prioritization manipulation, potentially leading to a denial of service (bsc#1146091).

- CVE-2019-9512: Fixed HTTP/2 flood using PING frames results in unbounded memory growth (bsc#1146099).

- CVE-2019-9513: Fixed HTTP/2 implementation that is vulnerable to resource loops, potentially leading to a denial of service. (bsc#1146094).

- CVE-2019-9514: Fixed HTTP/2 implementation that is vulnerable to a reset flood, potentially leading to a denial of service (bsc#1146095).

- CVE-2019-9515: Fixed HTTP/2 flood using SETTINGS frames results in unbounded memory growth (bsc#1146100).

- CVE-2019-9516: Fixed HTTP/2 implementation that is vulnerable to a header leak, potentially leading to a denial of service (bsc#1146090).

- CVE-2019-9517: Fixed HTTP/2 implementations that are vulnerable to unconstrained interal data buffering (bsc#1146097).

- CVE-2019-9518: Fixed HTTP/2 implementation that is vulnerable to a flood of empty frames, potentially leading to a denial of service (bsc#1146093).

Bug fixes :

- Fixed that npm resolves its default config file like in all other versions, as /etc/nodejs/npmrc (bsc#1144919).

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected nodejs8 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1144919

https://bugzilla.opensuse.org/show_bug.cgi?id=1146090

https://bugzilla.opensuse.org/show_bug.cgi?id=1146091

https://bugzilla.opensuse.org/show_bug.cgi?id=1146093

https://bugzilla.opensuse.org/show_bug.cgi?id=1146094

https://bugzilla.opensuse.org/show_bug.cgi?id=1146095

https://bugzilla.opensuse.org/show_bug.cgi?id=1146097

https://bugzilla.opensuse.org/show_bug.cgi?id=1146099

https://bugzilla.opensuse.org/show_bug.cgi?id=1146100

Plugin Details

Severity: High

ID: 128669

File Name: openSUSE-2019-2115.nasl

Version: 1.3

Type: local

Agent: unix

Published: 9/11/2019

Updated: 9/23/2020

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nodejs8, p-cpe:/a:novell:opensuse:nodejs8-debuginfo, p-cpe:/a:novell:opensuse:nodejs8-debugsource, p-cpe:/a:novell:opensuse:nodejs8-devel, p-cpe:/a:novell:opensuse:npm8, cpe:/o:novell:opensuse:15.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 9/10/2019

Vulnerability Publication Date: 8/13/2019

Reference Information

CVE: CVE-2019-9511, CVE-2019-9512, CVE-2019-9513, CVE-2019-9514, CVE-2019-9515, CVE-2019-9516, CVE-2019-9517, CVE-2019-9518