Scientific Linux Security Update : libtiff on SL7.x x86_64

Medium Nessus Plugin ID 128236

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

Security Fix(es) :

- libtiff: buffer overflow in gif2tiff (CVE-2016-3186)

- libtiff: Heap-based buffer overflow in the cpSeparateBufToContigBuf function resulting in a denial of service or possibly code execution (CVE-2018-12900)

- libtiff: Out-of-bounds write in tif_jbig.c (CVE-2018-18557)

- libtiff: NULL pointer dereference in tif_print.c:TIFFPrintDirectory() causes a denial of service (CVE-2018-7456)

- libtiff: heap-based buffer overflow in tif_lzw.c:LZWDecodeCompat() allows for denial of service (CVE-2018-8905)

- libtiff: heap-based buffer over-read in TIFFWriteScanline function in tif_write.c (CVE-2018-10779)

- libtiff: reachable assertion in TIFFWriteDirectorySec function in tif_dirwrite.c (CVE-2018-10963)

- libtiff: Integer overflow in multiply_ms in tools/ppm2tiff.c (CVE-2018-17100)

- libtiff: Two out-of-bounds writes in cpTags in tools/tiff2bw.c and tools/pal2rgb.c (CVE-2018-17101)

- libtiff: tiff2bw tool failed memory allocation leads to crash (CVE-2018-18661)

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?14624296

Plugin Details

Severity: Medium

ID: 128236

File Name: sl_20190806_libtiff_on_SL7_x.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/08/27

Updated: 2019/09/24

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/08/06

Vulnerability Publication Date: 2016/04/19

Reference Information

CVE: CVE-2016-3186, CVE-2018-10779, CVE-2018-10963, CVE-2018-12900, CVE-2018-17100, CVE-2018-17101, CVE-2018-18557, CVE-2018-18661, CVE-2018-7456, CVE-2018-8905