Flexera FlexNet Publisher < 11.16.2 Multiple Vulnerabilities

critical Nessus Plugin ID 128148
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A licensing application running on the remote host is affected by multiple vulnerabilities.

Description

The version of Flexera FlexNet Publisher running on the remote host is prior to 11.16.2. It is, therefore, affected by multiple vulnerabilities :

- A Denial of Service vulnerability related to preemptive item deletion in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier allows a remote attacker to send a combination of messages to lmgrd or the vendor daemon, causing the heartbeat between lmgrd and the vendor daemon to stop, and the vendor daemon to shut down. (CVE-2018-20031)

- A Denial of Service vulnerability related to message decoding in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier allows a remote attacker to send a combination of messages to lmgrd or the vendor daemon, causing the heartbeat between lmgrd and the vendor daemon to stop, and the vendor daemon to shut down. (CVE-2018-20032)

- A Remote Code Execution vulnerability in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier could allow a remote attacker to corrupt the memory by allocating / deallocating memory, loading lmgrd or the vendor daemon and causing the heartbeat between lmgrd and the vendor daemon to stop. This would force the vendor daemon to shut down.
(CVE-2018-20033)

- A Denial of Service vulnerability related to adding an item to a list in lmgrd and vendor daemon components of FlexNet Publisher version 11.16.1.0 and earlier allows a remote attacker to send a combination of messages to lmgrd or the vendor daemon, causing the heartbeat between lmgrd and the vendor daemon to stop, and the vendor daemon to shut down. (CVE-2018-20034)

Solution

Upgrade to FlexNet Publisher 11.16.2 or later.

See Also

http://www.nessus.org/u?eb4f204b

http://www.nessus.org/u?fbd5ba7b

Plugin Details

Severity: Critical

ID: 128148

File Name: flexnet_publisher_11_6_2_multi_vulns.nasl

Version: 1.3

Type: remote

Family: Misc.

Published: 8/26/2019

Updated: 2/12/2021

Dependencies: flexnet_publisher_detection.nbin, netscaler_mas_web_detect.nasl

Risk Information

CVSS Score Source: CVE-2018-20033

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:flexerasoftware:flexnet_publisher

Required KB Items: Services/flexnet_publisher

Exploit Ease: No known exploits are available

Patch Publication Date: 7/11/2019

Vulnerability Publication Date: 7/11/2019

Reference Information

CVE: CVE-2018-20031, CVE-2018-20032, CVE-2018-20033, CVE-2018-20034

BID: 109155

ICSA: 19-192-07