openSUSE Security Update : mariadb / mariadb-connector-c (openSUSE-2019-1915)

Medium Nessus Plugin ID 128007

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for mariadb and mariadb-connector-c fixes the following issues :

mariadb :

- Update to version 10.2.25 (bsc#1136035)

- CVE-2019-2628: Fixed a remote denial of service by an privileged attacker (bsc#1136035).

- CVE-2019-2627: Fixed another remote denial of service by an privileged attacker (bsc#1136035).

- CVE-2019-2614: Fixed a potential remote denial of service by an privileged attacker (bsc#1136035).

- Fixed reading options for multiple instances if my${INSTANCE}.cnf is used (bsc#1132666)

mariadb-connector-c :

- Update to version 3.1.2 (bsc#1136035)

- Moved libmariadb.pc from /usr/lib/pkgconfig to /usr/lib64/pkgconfig for x86_64 (bsc#1126088)

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected mariadb / mariadb-connector-c packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1126088

https://bugzilla.opensuse.org/show_bug.cgi?id=1132666

https://bugzilla.opensuse.org/show_bug.cgi?id=1136035

Plugin Details

Severity: Medium

ID: 128007

File Name: openSUSE-2019-1915.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/08/20

Updated: 2019/08/20

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

CVSS v3.0

Base Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libmariadb-devel, p-cpe:/a:novell:opensuse:libmariadb-devel-debuginfo, p-cpe:/a:novell:opensuse:libmariadb3, p-cpe:/a:novell:opensuse:libmariadb3-32bit, p-cpe:/a:novell:opensuse:libmariadb3-32bit-debuginfo, p-cpe:/a:novell:opensuse:libmariadb3-debuginfo, p-cpe:/a:novell:opensuse:libmariadb_plugins, p-cpe:/a:novell:opensuse:libmariadb_plugins-debuginfo, p-cpe:/a:novell:opensuse:libmariadbprivate, p-cpe:/a:novell:opensuse:libmariadbprivate-debuginfo, p-cpe:/a:novell:opensuse:libmysqld-devel, p-cpe:/a:novell:opensuse:libmysqld19, p-cpe:/a:novell:opensuse:libmysqld19-debuginfo, p-cpe:/a:novell:opensuse:mariadb, p-cpe:/a:novell:opensuse:mariadb-bench, p-cpe:/a:novell:opensuse:mariadb-bench-debuginfo, p-cpe:/a:novell:opensuse:mariadb-client, p-cpe:/a:novell:opensuse:mariadb-client-debuginfo, p-cpe:/a:novell:opensuse:mariadb-connector-c-debugsource, p-cpe:/a:novell:opensuse:mariadb-debuginfo, p-cpe:/a:novell:opensuse:mariadb-debugsource, p-cpe:/a:novell:opensuse:mariadb-errormessages, p-cpe:/a:novell:opensuse:mariadb-galera, p-cpe:/a:novell:opensuse:mariadb-test, p-cpe:/a:novell:opensuse:mariadb-test-debuginfo, p-cpe:/a:novell:opensuse:mariadb-tools, p-cpe:/a:novell:opensuse:mariadb-tools-debuginfo, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2019/08/15

Vulnerability Publication Date: 2019/04/23

Reference Information

CVE: CVE-2019-2614, CVE-2019-2627, CVE-2019-2628