openSUSE Security Update : polkit (openSUSE-2019-1914)

Medium Nessus Plugin ID 128006

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for polkit fixes the following issues :

Security issue fixed :

- CVE-2019-6133: Fixed improper caching of auth decisions, which could bypass uid checking in the interactive backend (bsc#1121826).

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected polkit packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1121826

Plugin Details

Severity: Medium

ID: 128006

File Name: openSUSE-2019-1914.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/08/20

Updated: 2019/08/20

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 6.7

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libpolkit0, p-cpe:/a:novell:opensuse:libpolkit0-32bit, p-cpe:/a:novell:opensuse:libpolkit0-32bit-debuginfo, p-cpe:/a:novell:opensuse:libpolkit0-debuginfo, p-cpe:/a:novell:opensuse:polkit, p-cpe:/a:novell:opensuse:polkit-debuginfo, p-cpe:/a:novell:opensuse:polkit-debugsource, p-cpe:/a:novell:opensuse:polkit-devel, p-cpe:/a:novell:opensuse:polkit-devel-debuginfo, p-cpe:/a:novell:opensuse:typelib-1_0-Polkit-1_0, cpe:/o:novell:opensuse:15.0, cpe:/o:novell:opensuse:15.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2019/08/15

Vulnerability Publication Date: 2019/01/11

Reference Information

CVE: CVE-2019-6133