Cisco Adaptive Security Appliance Software and Cisco Firepower Threat Defense Software Denial of Service Vulnerability

High Nessus Plugin ID 127893

Synopsis

The remote device is missing a vendor-supplied security patch

Description

According to its self-reported version, the TCP syslog module of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to exhaust the 1550-byte buffers on an affected device, resulting in a denial of service (DoS) condition. The vulnerability is due to a missing boundary check in an internal function. An attacker could exploit this vulnerability by establishing a man-in-the-middle position between an affected device and its configured TCP syslog server and then maliciously modifying the TCP header in segments that are sent from the syslog server to the affected device. A successful exploit could allow the attacker to exhaust buffer on the affected device and cause all TCP-based features to stop functioning, resulting in a DoS condition. The affected TCP-based features include AnyConnect SSL VPN, clientless SSL VPN, and management connections such as Secure Shell (SSH), Telnet, and HTTPS.

Please see the included Cisco BIDs and Cisco Security Advisory for more information

Solution

Upgrade to the relevant fixed version referenced in Cisco bug ID CSCvh73829

See Also

http://www.nessus.org/u?6fd359b3

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvh73829

Plugin Details

Severity: High

ID: 127893

File Name: cisco-sa-20181003-asa-syslog-dos.nasl

Version: 1.1

Type: local

Family: CISCO

Published: 2019/08/14

Updated: 2019/08/14

Dependencies: 12634, 11936

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-15399

CVSS v2.0

Base Score: 7.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

CVSS v3.0

Base Score: 6.8

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/o:cisco:firepower_threat_defense, cpe:/a:cisco:adaptive_security_appliance_software

Required KB Items: Host/Cisco/ASA, Host/Cisco/show_ver, Host/Cisco/ASA/model, Settings/ParanoidReport

Patch Publication Date: 2018/10/03

Vulnerability Publication Date: 2018/10/03

Reference Information

CVE: CVE-2018-15399

CISCO-BUG-ID: CSCvh73829

CISCO-SA: cisco-sa-20181003-asa-syslog-dos

IAVA: 2019-A-0271

CWE: 332