PHP 7.3.x < 7.3.8 Multiple Vulnerabilities.

Medium Nessus Plugin ID 127132


An application installed on the remote host is affected by multiple vulnerabilities.


According to its banner, the version of PHP running on the remote web server is 7.3.x prior to 7.3.8. It is, therefore, affected by buffer overflow vulnerabilities in exif_read_data and exif_scan_thumbnail functions.


Upgrade to PHP version 7.3.8 or later.

See Also

Plugin Details

Severity: Medium

ID: 127132

File Name: php_7_3_8.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2019/08/12

Updated: 2019/10/31

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-11042

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/08/01

Vulnerability Publication Date: 2019/08/01

Reference Information

CVE: CVE-2019-11041, CVE-2019-11042