PHP 7.1.x < 7.1.31 Multiple Vulnerabilities.

Medium Nessus Plugin ID 127130


An application installed on the remote host is affected by multiple vulnerabilities.


According to its banner, the version of PHP running on the remote web server is 7.3.x prior to 7.1.31. It is, therefore, affected by buffer overflow vulnerabilities in exif_read_data and exif_scan_thumbnail functions.


Upgrade to PHP version 7.1.31 or later.

See Also

Plugin Details

Severity: Medium

ID: 127130

File Name: php_7_1_31.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/08/12

Updated: 2019/09/06

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-11041

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:L/AC:L/Au:S/C:C/I:C/A:C

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Patch Publication Date: 2019/08/01

Vulnerability Publication Date: 2019/08/01

Reference Information

CVE: CVE-2019-11041, CVE-2019-11042