Splunk Enterprise 6.0.x < 6.0.15, 6.1.x < 6.1.14, 6.2.x < 6.2.14, 6.3.x < 6.3.12, 6.4.x < 6.4.9, 6.5.x < 6.5.5 or Splunk Light < 6.6.0 Persistent XSS

Low Nessus Plugin ID 126702

Synopsis

An application running on a remote web server host is affected by a persistent cross-site scripting vulnerability

Description

According to its self-reported version number, the version of Splunk running on the remote web server is Splunk Enterprise 6.0.x prior to 6.0.15, 6.1.x prior to 6.1.14, 6.2.x prior to 6.2.14, 6.3.x prior to 6.3.12, 6.4.x prior to 6.4.9, 6.5.x prior to 6.5.5 or Splunk Light prior to 6.6.0.

It is, therefore, affected by a persistent XSS vulnerability due to improperly validated user-supplied input.
(CVE-2019-5727) An attacker can leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade Splunk Enterprise to version 6.0.15 / 6.1.14 / 6.2.14 / 6.3.12 / 6.4.9 / 6.5.5 or later or Splunk Light to version 6.6.0 or later

See Also

https://www.splunk.com/view/SP-CAAAQAF

Plugin Details

Severity: Low

ID: 126702

File Name: splunk_660.nasl

Version: 1.2

Type: remote

Published: 2019/07/16

Updated: 2019/10/18

Dependencies: 47619, 49069

Risk Information

Risk Factor: Low

CVSS Score Source: CVE-2019-5727

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/02/19

Vulnerability Publication Date: 2019/02/21

Reference Information

CVE: CVE-2019-5727

BID: 107113