Splunk Enterprise 6.0.x < 6.0.15, 6.1.x < 6.1.14, 6.2.x < 6.2.14, 6.3.x < 6.3.12, 6.4.x < 6.4.9, 6.5.x < 6.5.5 or Splunk Light < 6.6.0 Persistent XSS
Low Nessus Plugin ID 126702
SynopsisAn application running on a remote web server host is affected by a persistent cross-site scripting vulnerability
DescriptionAccording to its self-reported version number, the version of Splunk running on the remote web server is Splunk Enterprise 6.0.x prior to 6.0.15, 6.1.x prior to 6.1.14, 6.2.x prior to 6.2.14, 6.3.x prior to 6.3.12, 6.4.x prior to 6.4.9, 6.5.x prior to 6.5.5 or Splunk Light prior to 6.6.0.
It is, therefore, affected by a persistent XSS vulnerability due to improperly validated user-supplied input.
(CVE-2019-5727) An attacker can leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site.
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.
SolutionUpgrade Splunk Enterprise to version 6.0.15 / 6.1.14 / 6.2.14 / 6.3.12 / 6.4.9 / 6.5.5 or later or Splunk Light to version 6.6.0 or later