Splunk Enterprise 6.0.x < 6.0.15, 6.1.x < 6.1.14, 6.2.x < 6.2.14, 6.3.x < 6.3.12, 6.4.x < 6.4.9, 6.5.x < 6.5.5 or Splunk Light < 6.6.0 Persistent XSS

medium Nessus Plugin ID 126702


An application running on a remote web server host is affected by a persistent cross-site scripting vulnerability


According to its self-reported version number, the version of Splunk running on the remote web server is Splunk Enterprise 6.0.x prior to 6.0.15, 6.1.x prior to 6.1.14, 6.2.x prior to 6.2.14, 6.3.x prior to 6.3.12, 6.4.x prior to 6.4.9, 6.5.x prior to 6.5.5 or Splunk Light prior to 6.6.0.

It is, therefore, affected by a persistent XSS vulnerability due to improperly validated user-supplied input.
(CVE-2019-5727) An attacker can leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade Splunk Enterprise to version 6.0.15 / 6.1.14 / 6.2.14 / 6.3.12 / 6.4.9 / 6.5.5 or later or Splunk Light to version 6.6.0 or later

See Also


Plugin Details

Severity: Medium

ID: 126702

File Name: splunk_660.nasl

Version: 1.2

Type: remote

Published: 7/16/2019

Updated: 10/18/2019

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2019-5727


Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Ease: No known exploits are available

Patch Publication Date: 2/19/2019

Vulnerability Publication Date: 2/21/2019

Reference Information

CVE: CVE-2019-5727

BID: 107113