SUSE SLED15 / SLES15 Security Update : gvfs (SUSE-SU-2019:1717-1)

Medium Nessus Plugin ID 126444

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for gvfs fixes the following issues :

Security issues fixed :

CVE-2019-12795: Fixed a vulnerability which could have allowed attacks via local D-Bus method calls (bsc#1137930).

CVE-2019-12447: Fixed an improper handling of file ownership in daemon/gvfsbackendadmin.c due to no use of setfsuid (bsc#1136986).

CVE-2019-12449: Fixed an improper handling of file's user and group ownership in daemon/gvfsbackendadmin.c (bsc#1136992).

CVE-2019-12448: Fixed race conditions in daemon/gvfsbackendadmin.c due to implementation of query_info_on_read/write at admin backend (bsc#1136981).

Other issue addressed: Drop polkit rules files that are only relevant for wheel group (bsc#1125433).

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1717=1

SUSE Linux Enterprise Module for Desktop Applications 15-SP1:zypper in
-t patch SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-1717=1

SUSE Linux Enterprise Module for Desktop Applications 15:zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-1717=1

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1125433

https://bugzilla.suse.com/show_bug.cgi?id=1136981

https://bugzilla.suse.com/show_bug.cgi?id=1136986

https://bugzilla.suse.com/show_bug.cgi?id=1136992

https://bugzilla.suse.com/show_bug.cgi?id=1137930

https://www.suse.com/security/cve/CVE-2019-12447/

https://www.suse.com/security/cve/CVE-2019-12448/

https://www.suse.com/security/cve/CVE-2019-12449/

https://www.suse.com/security/cve/CVE-2019-12795/

http://www.nessus.org/u?7b401e56

Plugin Details

Severity: Medium

ID: 126444

File Name: suse_SU-2019-1717-1.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2019/07/02

Updated: 2019/11/12

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:gvfs, p-cpe:/a:novell:suse_linux:gvfs-32bit-debuginfo, p-cpe:/a:novell:suse_linux:gvfs-backend-afc, p-cpe:/a:novell:suse_linux:gvfs-backend-afc-debuginfo, p-cpe:/a:novell:suse_linux:gvfs-backend-samba, p-cpe:/a:novell:suse_linux:gvfs-backend-samba-debuginfo, p-cpe:/a:novell:suse_linux:gvfs-backends, p-cpe:/a:novell:suse_linux:gvfs-backends-debuginfo, p-cpe:/a:novell:suse_linux:gvfs-debuginfo, p-cpe:/a:novell:suse_linux:gvfs-debugsource, p-cpe:/a:novell:suse_linux:gvfs-devel, p-cpe:/a:novell:suse_linux:gvfs-fuse, p-cpe:/a:novell:suse_linux:gvfs-fuse-debuginfo, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2019/07/01

Vulnerability Publication Date: 2019/05/29

Reference Information

CVE: CVE-2019-12447, CVE-2019-12448, CVE-2019-12449, CVE-2019-12795