openSUSE Security Update : aubio (openSUSE-2019-1618)

critical Nessus Plugin ID 126234

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for aubio fixes the following issues :

Fixed security issues leading to buffer overflows or segfaults (CVE-2018-19800, boo#1137828, CVE-2018-19801, boo#1137822, CVE-2018-19802, boo#1137823) :

Solution

Update the affected aubio packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1137822

https://bugzilla.opensuse.org/show_bug.cgi?id=1137823

https://bugzilla.opensuse.org/show_bug.cgi?id=1137828

Plugin Details

Severity: Critical

ID: 126234

File Name: openSUSE-2019-1618.nasl

Version: 1.4

Type: local

Agent: unix

Published: 6/25/2019

Updated: 9/23/2020

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:aubio-debugsource, p-cpe:/a:novell:opensuse:aubio-tools, p-cpe:/a:novell:opensuse:aubio-tools-debuginfo, p-cpe:/a:novell:opensuse:libaubio-devel, p-cpe:/a:novell:opensuse:libaubio5, p-cpe:/a:novell:opensuse:libaubio5-32bit, p-cpe:/a:novell:opensuse:libaubio5-32bit-debuginfo, p-cpe:/a:novell:opensuse:libaubio5-debuginfo, p-cpe:/a:novell:opensuse:python-aubio-debugsource, p-cpe:/a:novell:opensuse:python2-aubio, p-cpe:/a:novell:opensuse:python2-aubio-debuginfo, p-cpe:/a:novell:opensuse:python3-aubio, p-cpe:/a:novell:opensuse:python3-aubio-debuginfo, cpe:/o:novell:opensuse:15.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 6/24/2019

Vulnerability Publication Date: 6/7/2019

Reference Information

CVE: CVE-2018-19800, CVE-2018-19801, CVE-2018-19802