FreeBSD : SA-04:06.ipv6 : setsockopt()

Low Nessus Plugin ID 12613


The remote device is missing a vendor-supplied security patch


The remote host is running a version of FreeBSD 5.2 older than FreeBSD 5.2.1-p4

There is a programming error in the version of this kernel which may allow a local attacker to read portions of the kernel memory or to cause a system panic by misusing the setsockopt() system call on IPv6 sockets.


Plugin Details

Severity: Low

ID: 12613

File Name: freebsd_setsockopt_521_4.nasl

Version: $Revision: 1.9 $

Published: 2004/07/06

Modified: 2013/01/25

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

Required KB Items: Host/FreeBSD/pkg_info

Reference Information

CVE: CVE-2004-0370