Fortinet FortiOS <= 5.4, 5.6.x < 5.6.8, 6.0.x < 6.0.5 SSL VPN Buffer Overflow (FG-IR-18-387)

high Nessus Plugin ID 125886
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is affected by a buffer overflow condition.

Description

The remote host is running a version of FortiOS prior or equal to 5.4, 5.6.x prior to 5.6.8 or 6.0.x prior to 6.0.5. It is, therefore, affected by a buffer overflow condition in the SSL-VPN web portal, due to a failure to properly parse message payloads. An unauthenticated attacker can exploit this, via a specially crafted request to cause a denial of service condition.

Solution

Upgrade to Fortinet FortiOS version to 5.6.8, 6.0.5, 6.2.0 or later. Alternatively, apply one of the workarounds outlined in the linked advisory

See Also

http://www.nessus.org/u?ffaddea9

Plugin Details

Severity: High

ID: 125886

File Name: fortios_FG-IR-18-387.nasl

Version: 1.7

Type: local

Family: Firewalls

Published: 6/14/2019

Updated: 4/29/2021

Dependencies: fortinet_version.nbin

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2018-13381

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:fortinet:fortios

Required KB Items: Host/Fortigate/version, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 5/17/2019

Vulnerability Publication Date: 5/17/2019

Reference Information

CVE: CVE-2018-13381

BID: 108440