Exim 4.87 < 4.92 Remote Command Execution

critical Nessus Plugin ID 125737
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote mail server is potentially affected by a remote command execution vulnerability.

Description

According to its banner, the version of Exim running on the remote host is between 4.87 and 4.91 (inclusive). It is, therefore, potentially affected by a remote command execution vulnerability. A flaw exists in the deliver_message() function that could allow an attacker to execute arbitrary commands via a specially crafted email.

Solution

Upgrade to Exim 4.92 or later.

See Also

http://www.nessus.org/u?16a2ac7f

http://www.nessus.org/u?9de8f07f

http://www.nessus.org/u?cf324cac

https://exim.org/static/doc/security/CVE-2019-10149.txt

ftp://ftp.exim.org/pub/exim/exim4/ChangeLog

Plugin Details

Severity: Critical

ID: 125737

File Name: exim_4_92.nasl

Version: 1.8

Type: remote

Published: 6/6/2019

Updated: 2/5/2021

Dependencies: smtpserver_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2019-10149

VPR

Risk Factor: Critical

Score: 9.5

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/10/2019

Vulnerability Publication Date: 6/5/2019

Exploitable With

CANVAS (CANVAS)

Metasploit (Exim 4.87 - 4.91 Local Privilege Escalation)

Reference Information

CVE: CVE-2019-10149