Exim 4.87 < 4.92 Remote Command Execution

High Nessus Plugin ID 125737


The remote mail server is potentially affected by a remote command execution vulnerability.


According to its banner, the version of Exim running on the remote host is between 4.87 and 4.91 (inclusive). It is, therefore, potentially affected by a remote command execution vulnerability. A flaw exists in the deliver_message() function that could allow an attacker to execute arbitrary commands via a specially crafted email.


Upgrade to Exim 4.92 or later.

See Also






Plugin Details

Severity: High

ID: 125737

File Name: exim_4_92.nasl

Version: 1.7

Type: remote

Published: 2019/06/06

Updated: 2020/01/09

Dependencies: 10263

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-10149

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/02/10

Vulnerability Publication Date: 2019/06/05

Exploitable With


Metasploit (Exim 4.87 - 4.91 Local Privilege Escalation)

Reference Information

CVE: CVE-2019-10149