MariaDB 10.2.0 < 10.2.17 Multiple Vulnerabilities

Medium Nessus Plugin ID 125730

Synopsis

The remote database server is affected by multiple vulnerabilities

Description

The version of MariaDB installed on the remote host is prior to 10.2.17. It is, therefore, affected by multiple vulnerabilities as referenced in the mdb-10217-rn advisory.

- An unspecified vulnerability exists in MariaDB. An authenticated, remote attacker can exploit this to compromise MariaDB server, resulting in unauthorized update, insert, delete and read access to some of accessible data. (CVE-2018-3058, CVE-2018-3060, CVE-2018-3066)

- A denial of service (DoS) vulnerability exists in MariaDB. An authenticated, remote attacker can exploit this issue, to cause the application to stop responding. (CVE-2018-3063, CVE-2018-3064)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 10.2.17 or later.

See Also

https://mariadb.com/kb/en/mdb-10217-rn

https://jira.mariadb.org/browse/MDEV-12837

https://jira.mariadb.org/browse/MDEV-14637

https://jira.mariadb.org/browse/MDEV-15822

https://jira.mariadb.org/browse/MDEV-15855

https://jira.mariadb.org/browse/MDEV-15953

https://jira.mariadb.org/browse/MDEV-16515

https://jira.mariadb.org/browse/MDEV-16596

https://jira.mariadb.org/browse/MDEV-16664

https://jira.mariadb.org/browse/MDEV-16713

https://jira.mariadb.org/browse/MDEV-16809

Plugin Details

Severity: Medium

ID: 125730

File Name: mariadb_10_2_17.nasl

Version: 1.1

Type: remote

Family: Databases

Published: 2019/06/05

Updated: 2019/06/05

Dependencies: 10719, 91823

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-3064

CVSS v2.0

Base Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P

CVSS v3.0

Base Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Patch Publication Date: 2018/07/20

Vulnerability Publication Date: 2018/07/18

Reference Information

CVE: CVE-2018-3058, CVE-2018-3060, CVE-2018-3063, CVE-2018-3064, CVE-2018-3066

BID: 104766, 104769, 104776, 104786