MariaDB 10.2.0 < 10.2.17 Multiple Vulnerabilities

high Nessus Plugin ID 125730


The remote database server is affected by multiple vulnerabilities


The version of MariaDB installed on the remote host is prior to 10.2.17. It is, therefore, affected by multiple vulnerabilities as referenced in the mdb-10217-rn advisory.

- An unspecified vulnerability exists in MariaDB. An authenticated, remote attacker can exploit this to compromise MariaDB server, resulting in unauthorized update, insert, delete and read access to some of accessible data. (CVE-2018-3058, CVE-2018-3060, CVE-2018-3066)

- A denial of service (DoS) vulnerability exists in MariaDB. An authenticated, remote attacker can exploit this issue, to cause the application to stop responding. (CVE-2018-3063, CVE-2018-3064)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to MariaDB version 10.2.17 or later.

See Also

Plugin Details

Severity: High

ID: 125730

File Name: mariadb_10_2_17.nasl

Version: 1.3

Type: remote

Family: Databases

Published: 6/5/2019

Updated: 5/25/2020

Supported Sensors: Frictionless Assessment Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 5.2


Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P

CVSS Score Source: CVE-2018-3064


Risk Factor: High

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Exploit Ease: No known exploits are available

Patch Publication Date: 7/20/2018

Vulnerability Publication Date: 7/18/2018

Reference Information

CVE: CVE-2018-3058, CVE-2018-3060, CVE-2018-3063, CVE-2018-3064, CVE-2018-3066

BID: 104766, 104769, 104776, 104786