FreeBSD : SA-04:10.cvs

High Nessus Plugin ID 12530


The remote device is missing a vendor-supplied security patch


The remote host is running a version of FreeBSD which contains a heap overflow in the cvs pserver code. This flaw may be used by an attacker to execute arbitrary code on the remote host, provided that it's running a cvs pserver.


Plugin Details

Severity: High

ID: 12530

File Name: freebsd_cvs_heap_overflow.nasl

Version: $Revision: 1.11 $

Published: 2004/07/06

Modified: 2010/10/06

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Required KB Items: Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Exploitable With


Reference Information

CVE: CVE-2004-0396

BID: 10384