OpenVPN 2.4.x < 2.4.6 Denial of Service Vulnerability (Windows)

high Nessus Plugin ID 125263
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

An application on the remote Windows host is affected by a denial of service vulnerability.

Description

According to its self-reported version number, the version of OpenVPN installed on the remote Windows host is affected by a denial of service (DoS) vulnerability in its interactive service helper component due to an invalid level of validation for incoming requests. An unauthenticated, local attacker can exploit this issue, by sending malformed requests, to cause the application to stop responding.

Solution

Upgrade to OpenVPN 2.4.6 or later.

See Also

http://www.nessus.org/u?d07ec3ea

Plugin Details

Severity: High

ID: 125263

File Name: openvpn_2_4_6.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 5/17/2019

Updated: 10/30/2019

Dependencies: openvpn_server_installed.nbin

Risk Information

CVSS Score Source: CVE-2018-9336

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openvpn:openvpn

Required KB Items: installed_sw/OpenVPN Server

Exploit Ease: No known exploits are available

Patch Publication Date: 4/24/2018

Vulnerability Publication Date: 5/1/2018

Reference Information

CVE: CVE-2018-9336