CVE-2018-9336

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

References

http://www.slackware.com/security/viewer.php?l=slackware-security&y=2018&m=slackware-security.568761

https://community.openvpn.net/openvpn/wiki/ChangesInOpenvpn24

https://github.com/OpenVPN/openvpn/commit/1394192b210cb3c6624a7419bcf3ff966742e79b

https://github.com/OpenVPN/openvpn/releases/tag/v2.4.6

https://www.tenable.com/security/research/tra-2018-09

Details

Source: MITRE

Published: 2018-05-01

Updated: 2018-06-13

Type: CWE-415

Risk Information

CVSS v2

Base Score: 4.6

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 3.9

Severity: MEDIUM

CVSS v3

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
125263OpenVPN 2.4.x < 2.4.6 Denial of Service Vulnerability (Windows)NessusWindows
high
123212openSUSE Security Update : openvpn (openSUSE-2019-507)NessusSuSE Local Security Checks
high
120034SUSE SLED15 / SLES15 Security Update : openvpn (SUSE-SU-2018:1888-1)NessusSuSE Local Security Checks
high
110961openSUSE Security Update : openvpn (openSUSE-2018-705)NessusSuSE Local Security Checks
high
109362Slackware 13.0 / 13.1 / 13.37 / 14.0 / 14.1 / 14.2 / current : openvpn (SSA:2018-116-01)NessusSlackware Local Security Checks
high