JQuery < 3.0.0 XSS

Medium Nessus Plugin ID 125152


The remote web server is affected by a cross site scripting vulnerability.


The version of JQuery library hosted on the remote web server is prior to 3.0.0. It is, therefore, affected by a cross site scripting vulnerability when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed


Upgrade to JQuery version 3.0.0 or later.

See Also


Plugin Details

Severity: Medium

ID: 125152

File Name: jquery_3_0_0.nasl

Version: 1.3

Type: remote

Published: 2019/05/15

Updated: 2019/10/30

Dependencies: 106658

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2015-9251

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport, installed_sw/jquery

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/06/09

Vulnerability Publication Date: 2016/06/09

Reference Information

CVE: CVE-2015-9251