JQuery < 3.0.0 XSS

medium Nessus Plugin ID 125152
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by a cross site scripting vulnerability.

Description

The version of JQuery library hosted on the remote web server is prior to 3.0.0. It is, therefore, affected by a cross site scripting vulnerability when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed

Solution

Upgrade to JQuery version 3.0.0 or later.

See Also

https://blog.jquery.com/2016/06/09/jquery-3-0-final-released/

Plugin Details

Severity: Medium

ID: 125152

File Name: jquery_3_0_0.nasl

Version: 1.3

Type: remote

Published: 5/15/2019

Updated: 10/30/2019

Dependencies: jquery_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2015-9251

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport, installed_sw/jquery

Exploit Ease: No known exploits are available

Patch Publication Date: 6/9/2016

Vulnerability Publication Date: 6/9/2016

Reference Information

CVE: CVE-2015-9251