FreeBSD : Flash Player -- arbitrary code execution (a99923a9-768c-11e9-885a-6451062f0f7a)

high Nessus Plugin ID 125099

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Adobe reports :

- This update resolves a use-after-free vulnerability that could lead to arbitrary code execution (CVE-2019-7837).

Solution

Update the affected package.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb19-26.html

http://www.nessus.org/u?235b05df

Plugin Details

Severity: High

ID: 125099

File Name: freebsd_pkg_a99923a9768c11e9885a6451062f0f7a.nasl

Version: 1.3

Type: local

Published: 5/15/2019

Updated: 1/17/2020

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-flashplayer, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Ease: No known exploits are available

Patch Publication Date: 5/14/2019

Vulnerability Publication Date: 5/14/2019

Reference Information

CVE: CVE-2019-7837