PHP 7.3.x < 7.3.5 Heap-based Buffer Overflow Vulnerability.

Medium Nessus Plugin ID 124764


An application installed on the remote host is affected by a heap-based buffer overflow vulnerability.


According to its banner, the version of PHP running on the remote web server is 7.3.x prior to 7.3.5. It is, therefore, affected by a heap-based buffer over-read condition within _estrndup of the exif_process_IFD_TAG in the exif.c script.
An unauthenticated, remote attacker can exploit this, to cause a denial of service condition or the execution of arbitrary code.


Upgrade to PHP version 7.3.5 or later.

See Also

Plugin Details

Severity: Medium

ID: 124764

File Name: php_7_3_5.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2019/05/10

Updated: 2019/10/30

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-11036

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/05/02

Vulnerability Publication Date: 2019/04/29

Reference Information

CVE: CVE-2019-11036