PHP 7.1.x < 7.1.29 Heap-based Buffer Overflow Vulnerability.

critical Nessus Plugin ID 124762
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

An application installed on the remote host is affected by a heap-based buffer overflow vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.29. It is, therefore, affected by a heap-based buffer over-read condition within _estrndup of the exif_process_IFD_TAG in the exif.c script.
An unauthenticated, remote attacker can exploit this, to cause a denial of service condition or the execution of arbitrary code.

Solution

Upgrade to PHP version 7.1.29 or later.

See Also

http://php.net/ChangeLog-7.php#7.1.29

Plugin Details

Severity: Critical

ID: 124762

File Name: php_7_1_29.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 5/10/2019

Updated: 10/30/2019

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2019-11036

VPR

Risk Factor: Medium

Score: 5.2

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 5/2/2019

Vulnerability Publication Date: 4/29/2019

Reference Information

CVE: CVE-2019-11036