PHP 7.1.x < 7.1.29 Heap-based Buffer Overflow Vulnerability.

Medium Nessus Plugin ID 124762


An application installed on the remote host is affected by a heap-based buffer overflow vulnerability.


According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.29. It is, therefore, affected by a heap-based buffer over-read condition within _estrndup of the exif_process_IFD_TAG in the exif.c script.
An unauthenticated, remote attacker can exploit this, to cause a denial of service condition or the execution of arbitrary code.


Upgrade to PHP version 7.1.29 or later.

See Also

Plugin Details

Severity: Medium

ID: 124762

File Name: php_7_1_29.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/05/10

Updated: 2019/06/07

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-11036

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Patch Publication Date: 2019/05/02

Vulnerability Publication Date: 2019/04/29

Reference Information

CVE: CVE-2019-11036