ISC BIND 9 Denial of Service Vulnerability (CVE-2018-5743)

Medium Nessus Plugin ID 124652

Synopsis

The remote name server is affected by a denial of service vulnerability.

Description

ISC BIND versions 9.9.x prior or equal to 9.10.8-P1, 9.11.x prior to 9.11.6-P1, 9.12.x prior to 9.12.4-P1, 9.13.0 prior or equal to 9.13.7, 9.14.0, and BIND 9 Supported Preview Edition versions 9.9.3-S1 prior or equal to to 9.11.5-S3, and 9.11.5-S5 are affected by a DoS vulnerability due to a flaw in the feature to limit the number of simultaneous TCP connections. An unauthenticated, remote attacker can exploit this issue, to cause the application to stop responding.

Solution

Upgrade to ISC BIND version 9.11.6-P1, 9.12.4-P1, 9.14.1, 9.11.5-S6, 9.11.6-S1 or later.

See Also

https://kb.isc.org/docs/aa-00861

https://kb.isc.org/docs/aa-00913

https://kb.isc.org/docs/cve-2018-5743

Plugin Details

Severity: Medium

ID: 124652

File Name: bind9_CVE-2018-5743.nasl

Version: 1.4

Type: remote

Family: DNS

Published: 2019/05/07

Updated: 2020/05/22

Dependencies: 10028

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-5743

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:isc:bind

Required KB Items: bind/version, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/04/24

Vulnerability Publication Date: 2019/04/24

Reference Information

CVE: CVE-2018-5743

BID: 108077

IAVA: 2019-A-0139-S