openSUSE Security Update : file (openSUSE-2019-1197)

Medium Nessus Plugin ID 124052

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for file fixes the following issues :

The following security vulnerabilities were addressed :

- Fixed an out-of-bounds read in the function do_core_note in readelf.c, which allowed remote attackers to cause a denial of service (application crash) via a crafted ELF file (bsc#1096974 CVE-2018-10360).

- CVE-2019-8905: Fixed a stack-based buffer over-read in do_core_note in readelf.c (bsc#1126118)

- CVE-2019-8906: Fixed an out-of-bounds read in do_core_note in readelf. c (bsc#1126119)

- CVE-2019-8907: Fixed a stack corruption in do_core_note in readelf.c (bsc#1126117)

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected file packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1096974

https://bugzilla.opensuse.org/show_bug.cgi?id=1096984

https://bugzilla.opensuse.org/show_bug.cgi?id=1126117

https://bugzilla.opensuse.org/show_bug.cgi?id=1126118

https://bugzilla.opensuse.org/show_bug.cgi?id=1126119

Plugin Details

Severity: Medium

ID: 124052

File Name: openSUSE-2019-1197.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/04/15

Updated: 2019/04/15

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:file, p-cpe:/a:novell:opensuse:file-debuginfo, p-cpe:/a:novell:opensuse:file-debugsource, p-cpe:/a:novell:opensuse:file-devel, p-cpe:/a:novell:opensuse:file-magic, p-cpe:/a:novell:opensuse:libmagic1, p-cpe:/a:novell:opensuse:libmagic1-32bit, p-cpe:/a:novell:opensuse:libmagic1-debuginfo, p-cpe:/a:novell:opensuse:libmagic1-debuginfo-32bit, p-cpe:/a:novell:opensuse:python-magic, cpe:/o:novell:opensuse:42.3

Patch Publication Date: 2019/04/12

Vulnerability Publication Date: 2018/06/11

Reference Information

CVE: CVE-2018-10360, CVE-2019-8905, CVE-2019-8906, CVE-2019-8907