PHP 7.1.x < 7.1.27 Multiple vulnerabilities.

critical Nessus Plugin ID 123827

Synopsis

An application installed on the remote host is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.27. It is, therefore, affected by multiple vulnerabilities:

- Uninitialized reads in the EXIF component of PHP due to the mishandling of data in exif_process_IFD_in_MAKERNOTE, and exif_process_IFD_in_TIFF. (CVE-2019-9638, CVE-2019-9639, CVE-2019-9641)

- An invalid read in the EXIF component of PHP due to a mishandling of data in exif_process_SOFn. (CVE-2019-9640)

- An access control bypass vulnerability exists due to the way rename() is implemented. This could allow unauthorized users to access data they otherwise would not have access to (CVE-2019-9637).

Solution

Upgrade to PHP version 7.1.27 or later.

See Also

http://php.net/ChangeLog-7.php#7.1.27

Plugin Details

Severity: Critical

ID: 123827

File Name: php_7_1_27.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 4/8/2019

Updated: 6/5/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2019-9641

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/7/2019

Vulnerability Publication Date: 3/7/2019

Reference Information

CVE: CVE-2019-9637, CVE-2019-9638, CVE-2019-9639, CVE-2019-9640, CVE-2019-9641

BID: 107379