CVE-2019-9638

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in the EXIF component in PHP before 7.1.27, 7.2.x before 7.2.16, and 7.3.x before 7.3.3. There is an uninitialized read in exif_process_IFD_in_MAKERNOTE because of mishandling the maker_note->offset relationship to value_len.

References

https://bugs.php.net/bug.php?id=77563

https://www.debian.org/security/2019/dsa-4403

https://usn.ubuntu.com/3922-1/

https://lists.debian.org/debian-lts-announce/2019/03/msg00043.html

https://usn.ubuntu.com/3922-2/

https://usn.ubuntu.com/3922-3/

http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html

https://security.netapp.com/advisory/ntap-20190502-0007/

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00012.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html

https://access.redhat.com/errata/RHSA-2019:2519

https://access.redhat.com/errata/RHSA-2019:3299

Details

Source: MITRE

Published: 2019-03-09

Updated: 2021-07-21

Type: CWE-119

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (16 total)

IDNameProductFamilySeverity
145814CentOS 8 : php:7.2 (CESA-2020:1624)NessusCentOS Local Security Checks
critical
136057RHEL 8 : php:7.2 (RHSA-2020:1624)NessusRed Hat Local Security Checks
critical
126035openSUSE Security Update : php7 (openSUSE-2019-1573)NessusSuSE Local Security Checks
critical
126034openSUSE Security Update : php7 (openSUSE-2019-1572)NessusSuSE Local Security Checks
critical
125850SUSE SLED15 / SLES15 Security Update : php7 (SUSE-SU-2019:1461-1)NessusSuSE Local Security Checks
critical
125700openSUSE Security Update : php5 (openSUSE-2019-1503)NessusSuSE Local Security Checks
high
125457SUSE SLES12 Security Update : php5 (SUSE-SU-2019:1325-1)NessusSuSE Local Security Checks
high
124401openSUSE Security Update : php7 (openSUSE-2019-1293)NessusSuSE Local Security Checks
critical
124271Ubuntu 14.04 LTS : PHP vulnerabilities (USN-3922-2)NessusUbuntu Local Security Checks
critical
124268SUSE SLES12 Security Update : php72 (SUSE-SU-2019:0988-1)NessusSuSE Local Security Checks
high
123829PHP 7.3.x < 7.3.3 Multiple vulnerabilities.NessusCGI abuses
critical
123828PHP 7.2.x < 7.2.16 Multiple vulnerabilities.NessusCGI abuses
critical
123827PHP 7.1.x < 7.1.27 Multiple vulnerabilities.NessusCGI abuses
critical
123826SUSE SLES11 Security Update : php53 (SUSE-SU-2019:14013-1)NessusSuSE Local Security Checks
critical
123528Debian DLA-1741-1 : php5 security updateNessusDebian Local Security Checks
critical
122722Debian DSA-4403-1 : php7.0 - security updateNessusDebian Local Security Checks
critical