openSUSE Security Update : gd (openSUSE-2019-1140)

High Nessus Plugin ID 123770

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for gd fixes the following issues :

Security issues fixed :

- CVE-2019-6977: Fixed a heap-based buffer overflow the GD Graphics Library used in the imagecolormatch function (bsc#1123361).

- CVE-2019-6978: Fixed a double free in the gdImage*Ptr() functions (bsc#1123522).

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected gd packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1123361

https://bugzilla.opensuse.org/show_bug.cgi?id=1123522

Plugin Details

Severity: High

ID: 123770

File Name: openSUSE-2019-1140.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/04/05

Updated: 2019/04/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gd, p-cpe:/a:novell:opensuse:gd-32bit, p-cpe:/a:novell:opensuse:gd-debuginfo, p-cpe:/a:novell:opensuse:gd-debuginfo-32bit, p-cpe:/a:novell:opensuse:gd-debugsource, p-cpe:/a:novell:opensuse:gd-devel, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/04/04

Vulnerability Publication Date: 2019/01/27

Reference Information

CVE: CVE-2019-6977, CVE-2019-6978