openSUSE Security Update : MozillaFirefox (openSUSE-2019-1077)

High Nessus Plugin ID 123541

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for MozillaFirefox fixes the following issues :

Mozilla Firefox was updated to 60.6.1esr / MFSA 2019-10 (bsc#1130262)

- CVE-2019-9810: IonMonkey MArraySlice has incorrect alias information

- CVE-2019-9813: Ionmonkey type confusion with __proto__ mutations

Mozilla Firefox was updated to 60.6.0esr / MFSA 2019-08 (boo#1129821)

- CVE-2019-9790: Use-after-free when removing in-use DOM elements

- CVE-2019-9791: Type inference is incorrect for constructors entered through on-stack replacement with IonMonkey

- CVE-2019-9792: IonMonkey leaks JS_OPTIMIZED_OUT magic value to script

- CVE-2019-9793: Improper bounds checks when Spectre mitigations are disabled

- CVE-2019-9794: Command line arguments not discarded during execution

- CVE-2019-9795: Type-confusion in IonMonkey JIT compiler

- CVE-2019-9796: Use-after-free with SMIL animation controller

- CVE-2018-18506: Proxy Auto-Configuration file can define localhost access to be proxied

- CVE-2019-9788: Memory safety bugs fixed in Firefox 66 and Firefox ESR 60.6

Mozilla Firefox 60.5.2esr also had one change :

- Fix a frequent crash when reading various Reuters news articles.

Solution

Update the affected MozillaFirefox packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1129821

https://bugzilla.opensuse.org/show_bug.cgi?id=1130262

Plugin Details

Severity: High

ID: 123541

File Name: openSUSE-2019-1077.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2019/04/01

Updated: 2019/04/29

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:MozillaFirefox, p-cpe:/a:novell:opensuse:MozillaFirefox-branding-upstream, p-cpe:/a:novell:opensuse:MozillaFirefox-buildsymbols, p-cpe:/a:novell:opensuse:MozillaFirefox-debuginfo, p-cpe:/a:novell:opensuse:MozillaFirefox-debugsource, p-cpe:/a:novell:opensuse:MozillaFirefox-devel, p-cpe:/a:novell:opensuse:MozillaFirefox-translations-common, p-cpe:/a:novell:opensuse:MozillaFirefox-translations-other, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/03/29

Vulnerability Publication Date: 2019/02/05

Reference Information

CVE: CVE-2018-18506, CVE-2019-9788, CVE-2019-9790, CVE-2019-9791, CVE-2019-9792, CVE-2019-9793, CVE-2019-9794, CVE-2019-9795, CVE-2019-9796, CVE-2019-9810, CVE-2019-9813