openSUSE Security Update : xen (openSUSE-2019-631) (Foreshadow)

medium Nessus Plugin ID 123273

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for xen fixes the following security issues :

- CVE-2018-3646: Systems with microprocessors utilizing speculative execution and address translations may have allowed unauthorized disclosure of information residing in the L1 data cache to an attacker with local user access with guest OS privilege via a terminal page fault and a side-channel analysis (bsc#1091107, bsc#1027519).

- Incorrect MSR_DEBUGCTL handling let guests enable BTS allowing a malicious or buggy guest administrator can lock up the entire host (bsc#1103276) This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected xen packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1027519

https://bugzilla.opensuse.org/show_bug.cgi?id=1091107

https://bugzilla.opensuse.org/show_bug.cgi?id=1103276

Plugin Details

Severity: Medium

ID: 123273

File Name: openSUSE-2019-631.nasl

Version: 1.4

Type: local

Agent: unix

Published: 3/27/2019

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.2

CVSS v2

Risk Factor: Medium

Base Score: 4.7

Temporal Score: 3.5

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:novell:opensuse:15.0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-debugsource:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-doc-html:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-libs-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-libs-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-tools:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-tools-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-tools-domu:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-tools-domu-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-libs-32bit-debuginfo:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 3/23/2019

Vulnerability Publication Date: 8/14/2018

Reference Information

CVE: CVE-2018-3646