openSUSE Security Update : kernel-firmware (openSUSE-2019-587) (Spectre)

Medium Nessus Plugin ID 123255

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for kernel-firmware to version 20180525 fixes the following issues :

This security issue was fixed :

- CVE-2017-5715: Prevent unauthorized disclosure of information to an attacker with local user access caused by speculative execution and indirect branch prediction (bsc#1095735)

This update was imported from the SUSE:SLE-15:Update update project.

Solution

Update the affected kernel-firmware packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1095735

Plugin Details

Severity: Medium

ID: 123255

File Name: openSUSE-2019-587.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2019/03/27

Updated: 2019/07/09

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.7

Temporal Score: 4.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 5.4

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:kernel-firmware, p-cpe:/a:novell:opensuse:ucode-amd, cpe:/o:novell:opensuse:15.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/03/23

Vulnerability Publication Date: 2018/01/04

Reference Information

CVE: CVE-2017-5715