Drupal 7.x < 7.65 / 8.5.x < 8.5.14 / 8.6.x < 8.6.13 XSS (SA-CORE-2019-004)

Low Nessus Plugin ID 123006


A PHP application running on the remote web server is affected by a cross site scripting vulnerability.


According to its self-reported version, the instance of Drupal running on the remote web server is 7.x prior to 7.65, 8.5.x prior to 8.5.14, or 8.6.x prior to 8.6.13. It is, therefore, affected by a cross site scripting (XSS) vulnerability in the File module/subsystem due to improper sanitization of data in uploaded files.


Upgrade to Drupal version 7.65 / 8.5.14 / 8.6.13 or later.

See Also





Plugin Details

Severity: Low

ID: 123006

File Name: drupal_8_6_13.nasl

Version: 1.4

Type: remote

Published: 2019/03/22

Updated: 2019/10/30

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Low

CVSS Score Source: CVE-2019-6341

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/03/20

Vulnerability Publication Date: 2019/03/20

Reference Information

CVE: CVE-2019-6341

IAVA: 2019-A-0092