PHP 7.3.x < 7.3.2 Information Disclosure.

Medium Nessus Plugin ID 122750

Synopsis

An application installed on the remote host is affected by an information disclosure vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.3.x prior to 7.3.2. It is, therefore, affected by:

- An out-of-bounds read error exists in the dns_get_record function due to improper parsing of DNS responses. An unauthenticated, remote attacker can exploit this, via a specially crafted DNS reply, to disclose memory contents.

Solution

Upgrade to PHP version 7.3.2 or later.

See Also

http://php.net/ChangeLog-7.php#7.3.2

Plugin Details

Severity: Medium

ID: 122750

File Name: php_7_3_2.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2019/03/11

Updated: 2019/10/31

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-9022

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/02/07

Vulnerability Publication Date: 2019/02/07

Reference Information

CVE: CVE-2019-9022

BID: 107154