CVE-2019-9022

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

An issue was discovered in PHP 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.2. dns_get_record misparses a DNS response, which can allow a hostile DNS server to cause PHP to misuse memcpy, leading to read operations going past the buffer allocated for DNS data. This affects php_parserr in ext/standard/dns.c for DNS_CAA and DNS_ANY queries.

References

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html

http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html

https://access.redhat.com/errata/RHSA-2019:2519

https://access.redhat.com/errata/RHSA-2019:3299

https://bugs.php.net/bug.php?id=77369

https://lists.debian.org/debian-lts-announce/2019/03/msg00043.html

https://security.netapp.com/advisory/ntap-20190321-0001/

https://usn.ubuntu.com/3902-1/

https://usn.ubuntu.com/3922-2/

https://usn.ubuntu.com/3922-3/

https://www.debian.org/security/2019/dsa-4398

https://www.tenable.com/security/tns-2019-07

Details

Source: MITRE

Published: 2019-02-22

Updated: 2019-06-18

Type: CWE-125

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
145814CentOS 8 : php:7.2 (CESA-2020:1624)NessusCentOS Local Security Checks
critical
136057RHEL 8 : php:7.2 (RHSA-2020:1624)NessusRed Hat Local Security Checks
critical
126035openSUSE Security Update : php7 (openSUSE-2019-1573)NessusSuSE Local Security Checks
critical
126034openSUSE Security Update : php7 (openSUSE-2019-1572)NessusSuSE Local Security Checks
critical
125850SUSE SLED15 / SLES15 Security Update : php7 (SUSE-SU-2019:1461-1)NessusSuSE Local Security Checks
critical
124271Ubuntu 14.04 LTS : PHP vulnerabilities (USN-3922-2)NessusUbuntu Local Security Checks
critical
123528Debian DLA-1741-1 : php5 security updateNessusDebian Local Security Checks
critical
98245PHP 5.6.x < 5.6.40 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98244PHP 7.1.x < 7.1.26 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98243PHP 7.2.x < 7.2.14 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98242PHP 7.3.x < 7.3.1 Multiple vulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98241PHP 7.3.x < 7.3.2 Information DisclosureWeb Application ScanningComponent Vulnerability
high
122750PHP 7.3.x < 7.3.2 Information Disclosure.NessusCGI abuses
high
122667Ubuntu 14.04 LTS / 16.04 LTS : php5, php7.0 vulnerabilities (USN-3902-1)NessusUbuntu Local Security Checks
critical
122517Debian DSA-4398-1 : php7.0 - security updateNessusDebian Local Security Checks
critical
121510PHP 7.1.x < 7.1.26 Multiple vulnerabilities.NessusCGI abuses
critical
121353PHP 7.2.x < 7.2.14 Multiple vulnerabilities.NessusCGI abuses
critical