PHP 7.2.x < 7.2.0 Heap-based Buffer Overflow Vulnerability

High Nessus Plugin ID 122544

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

An application installed on the remote host is affected by a heap-based buffer overflow vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.23. It is, therefore, affected by a heap-based buffer overflow condition exists in the ext/standard/var_unserializer.re script due to improper use of the hash API for key deletion. An unauthenticated, remote attacker can exploit this to cause a denial of service condition or the execution of arbitrary code.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.2.0 or later.

See Also

http://php.net/ChangeLog-7.php#7.2.0

Plugin Details

Severity: High

ID: 122544

File Name: php_7_2_0.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/03/01

Updated: 2019/10/31

Dependencies: 48243

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS Score Source: CVE-2017-12932

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/08/31

Vulnerability Publication Date: 2017/08/17

Reference Information

CVE: CVE-2017-12932

BID: 100427